亚洲免费在线-亚洲免费在线播放-亚洲免费在线观看-亚洲免费在线观看视频-亚洲免费在线看-亚洲免费在线视频

POJ ACM習(xí)題【No.1003】

系統(tǒng) 2056 0
Hangover
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 42388 Accepted: 19686

Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/( n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/( n + 1). This is illustrated in the figure below.


POJ ACM習(xí)題【No.1003】

Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

Sample Input

    1.00
3.71
0.04
5.19
0.00

  

Sample Output

    3 card(s)
61 card(s)
1 card(s)
273 card(s)
  

?

解題思路:最小的張數(shù)就是大于總長度的第一個數(shù)字,注意使用浮點數(shù)。

?

?

    import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		String str;
		int maxCardNum = 0;
		
		while(cin.hasNext())
		{
			str = cin.nextLine();
			if(str.equals("0.00"))
				break;
			
			float len = Float.valueOf(str).floatValue();
			
			maxCardNum = getCardNum(len);
			System.out.println(maxCardNum + " card(s)");
		}

	}
	
	private static int getCardNum(float len)
	{
		float value = 0;
		int index = 2;
		
		while (value < len)
		{
			value += 1.0/index;
			index++;
		}
			
		return index-2;
	}

}

  
?

POJ ACM習(xí)題【No.1003】


更多文章、技術(shù)交流、商務(wù)合作、聯(lián)系博主

微信掃碼或搜索:z360901061

微信掃一掃加我為好友

QQ號聯(lián)系: 360901061

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描下面二維碼支持博主2元、5元、10元、20元等您想捐的金額吧,狠狠點擊下面給點支持吧,站長非常感激您!手機微信長按不能支付解決辦法:請將微信支付二維碼保存到相冊,切換到微信,然后點擊微信右上角掃一掃功能,選擇支付二維碼完成支付。

【本文對您有幫助就好】

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描上面二維碼支持博主2元、5元、10元、自定義金額等您想捐的金額吧,站長會非常 感謝您的哦!!!

發(fā)表我的評論
最新評論 總共0條評論
主站蜘蛛池模板: 99久久精品免费看国产交换 | 中文国产成人精品久久久 | 婷婷啪啪| 精品伊人久久久99热这里只 | 四虎高清成人永久免费影院 | 国语毛片| 视频一区二区在线 | 成 人 黄 色 | 欧美成人免费观看国产 | 九九热在线观看 | 夜夜摸夜夜操 | 国产高清国产精品国产k | 在线播放福利 | 精品国产第一国产综合精品gif | 青草91视频免费观看 | 日日操夜夜爽 | 国产亚洲精品一区久久 | 国产欧美日韩一区二区三区视频 | 久久久99精品免费观看精品 | 激情影院在线观看 | 91麻豆精品一二三区在线 | 国产精品国产三级国产a | 亚洲精品久久久午夜伊人 | 91香蕉黄| 久久97久久97精品免视看 | 亚洲精品综合一二三区在线 | 免费视频精品一区二区三区 | 成人短视频网站 | 欧美日韩无线码在线观看 | 日韩欧美精品在线视频 | 国产在线不卡视频 | 4hu四虎永久网址 | 国产精品午夜性视频 | 日韩精品一区二区三区国语自制 | 亚洲毛片 | 久久中文字幕免费 | 日本一级毛片免费播放 | 天天摸天天碰色综合网 | 久久久91精品国产一区二区 | 操夜夜 | 综合久久久久综合 |