亚洲免费在线-亚洲免费在线播放-亚洲免费在线观看-亚洲免费在线观看视频-亚洲免费在线看-亚洲免费在线视频

POJ ACM習(xí)題【No.1003】

系統(tǒng) 2056 0
Hangover
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 42388 Accepted: 19686

Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/( n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/( n + 1). This is illustrated in the figure below.


POJ ACM習(xí)題【No.1003】

Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

Sample Input

    1.00
3.71
0.04
5.19
0.00

  

Sample Output

    3 card(s)
61 card(s)
1 card(s)
273 card(s)
  

?

解題思路:最小的張數(shù)就是大于總長度的第一個數(shù)字,注意使用浮點數(shù)。

?

?

    import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		String str;
		int maxCardNum = 0;
		
		while(cin.hasNext())
		{
			str = cin.nextLine();
			if(str.equals("0.00"))
				break;
			
			float len = Float.valueOf(str).floatValue();
			
			maxCardNum = getCardNum(len);
			System.out.println(maxCardNum + " card(s)");
		}

	}
	
	private static int getCardNum(float len)
	{
		float value = 0;
		int index = 2;
		
		while (value < len)
		{
			value += 1.0/index;
			index++;
		}
			
		return index-2;
	}

}

  
?

POJ ACM習(xí)題【No.1003】


更多文章、技術(shù)交流、商務(wù)合作、聯(lián)系博主

微信掃碼或搜索:z360901061

微信掃一掃加我為好友

QQ號聯(lián)系: 360901061

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描下面二維碼支持博主2元、5元、10元、20元等您想捐的金額吧,狠狠點擊下面給點支持吧,站長非常感激您!手機微信長按不能支付解決辦法:請將微信支付二維碼保存到相冊,切換到微信,然后點擊微信右上角掃一掃功能,選擇支付二維碼完成支付。

【本文對您有幫助就好】

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描上面二維碼支持博主2元、5元、10元、自定義金額等您想捐的金額吧,站長會非常 感謝您的哦!!!

發(fā)表我的評論
最新評論 總共0條評論
主站蜘蛛池模板: 老子影院午夜伦手机在线看 | 国产www在线观看 | 99精品国产自产在线观看 | 日韩中文字幕网 | 亚洲精品视频久久 | 久久亚洲国产精品一区二区 | 天海翼一区二区三区高清视频 | 在线欧美精品一区二区三区 | 国产香蕉国产精品偷在线观看 | 奇米888第四色 | 伊人a.v在线| 国产伊人久久 | 老司机深夜福利网站 | 亚洲综合网在线观看首页 | 久久精彩免费视频 | 狠狠狠色丁香婷婷综合久久五月 | 精品视频 九九九 | 国产一及毛片 | 色视频免费国产观看 | 伊人久久精品亚洲午夜 | 国产成人亚洲精品2020 | 欧美综合区 | 亚洲综合在线视频 | 国产精品深夜福利免费观看 | 久久国产欧美另类久久久 | 香蕉视频网站入口 | 欧美日韩高清在线 | 日日摸夜夜摸狠狠摸97 | 欧美乱理伦另类视频 | 日本亚洲一区二区三区 | 国产在线麻豆一区二区 | 婷婷色网站 | 羞羞在线 | 午夜看毛片 | 午夜在线社区视频 | 久久网站在线观看 | 性视频一区二区三区免费 | 四虎8848精品永久在线观看 | 草莓视频caomei888 | 四虎三级| 97影院理论|