亚洲免费在线-亚洲免费在线播放-亚洲免费在线观看-亚洲免费在线观看视频-亚洲免费在线看-亚洲免费在线视频

POJ ACM習題【No.2924】

系統 1683 0
Gau? in Elementary School
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5129 Accepted: 2259

Description

Johann Carl Friedrich Gau? (1777 – 1855) was one of the most important German mathematicians. For those of you who remember the Deutsche Mark, a picture of him was printed on the 10 – DM bill. In elementary school, his teacher J. G. Büttner tried to occupy the pupils by making them add up the integers from 1 to 100. The young Gau? surprised everybody by producing the correct answers (5050) within seconds.

Can you write a computer program that can compute such sums really quickly?

Given two integers n and m , you should compute the sum of all the integers from n to m . In other words, you should compute

Input

The first line contains the number of scenarios. Each scenario consists of a line containing the numbers n and m (?10 9 n m ≤ 10 9 ).


Output

The output for every scenario begins with a line containing “ Scenario # i : ”, where i is the number of the scenario starting at 1. Then print the sum of all integers from n to m . Terminate the output for the scenario with a blank line.

Sample Input

    3
1 100
-11 10
-89173 938749341
  

Sample Output

    Scenario #1:
5050

Scenario #2:
-11

Scenario #3:
440625159107385260
  

?

要注意最大值的限制,雖然最大的輸入在Int范圍內,但是結果值將遠遠超過Int取值范圍

?

    import java.util.*;
import java.math.*;

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		
		int num = Integer.valueOf(cin.nextLine()).intValue();
		
		for(int i = 0; i < num; i++)
		{
			String[] str = cin.nextLine().split(" ");
			BigInteger a = new BigInteger(str[0]);
			BigInteger b = new BigInteger(str[1]);
			BigInteger result = new BigInteger("0");
			
			if((a.intValue() >= 0 && b.intValue() >= 0) 
					|| (a.intValue() < 0 && b.intValue() < 0))
			{
				int times = (Math.abs(b.intValue()-a.intValue())+1);
				result = result.add(a);
				result = result.add(b);
				result = result.multiply(new BigInteger(times + ""));
				result = result.divide(new BigInteger("2"));
			}
			else
			{
				int times1 = (Math.abs(b.intValue()-0)+1);
				BigInteger r1 = new BigInteger("0");
				r1 = r1.add(b);
				r1 = r1.multiply(new BigInteger(times1 + ""));
				r1 = r1.divide(new BigInteger("2"));
				
				int times2 = (Math.abs(a.intValue()-0)+1);
				BigInteger r2 = new BigInteger("0");
				r2 = r2.add(a);
				r2 = r2.multiply(new BigInteger(times2 + ""));
				r2 = r2.divide(new BigInteger("2"));
				
				result = r1.add(r2);
			}
	
			System.out.println("Scenario #" + (i+1) + ":");
			System.out.println(result.toString());
			if(i != num-1)
				System.out.println();
		}

	}

}

  
?

?

?

POJ ACM習題【No.2924】


更多文章、技術交流、商務合作、聯系博主

微信掃碼或搜索:z360901061

微信掃一掃加我為好友

QQ號聯系: 360901061

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描下面二維碼支持博主2元、5元、10元、20元等您想捐的金額吧,狠狠點擊下面給點支持吧,站長非常感激您!手機微信長按不能支付解決辦法:請將微信支付二維碼保存到相冊,切換到微信,然后點擊微信右上角掃一掃功能,選擇支付二維碼完成支付。

【本文對您有幫助就好】

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描上面二維碼支持博主2元、5元、10元、自定義金額等您想捐的金額吧,站長會非常 感謝您的哦!!!

發表我的評論
最新評論 總共0條評論
主站蜘蛛池模板: 九九影院理论片私人影院 | 激情五月婷婷网 | 天天视频国产精品 | 久久综合九九亚洲一区 | 欧美香蕉视频在线观看 | 精品在线播放视频 | 免费的性生活视频 | 国产精品美女www爽爽爽视频 | 亚洲国产欧美在线 | 男女一级特黄a大片 | 国语一区 | 福利岛国深夜在线 | 欧美v在线| 亚洲欧美在线中文字幕不卡 | 国产h版大片在线播放 | 2019年国产不卡在线刷新 | 伊人久久中文字幕 | 99久久99久久精品国产 | 99精品国产高清一区二区麻豆 | 国产高h| 女人l8毛片a一级毛片免费 | 一本伊在人香蕉线观新在线 | 国产精品国产亚洲精品看不卡 | 国产一区二区三区欧美 | 久久99热这里只有精品高清 | 非常色的视频 | 伊人久久精品线影院 | 久久久久在线观看 | 久草国产精品视频 | 日日摸夜夜添夜夜添影院视频 | 精品久久久久久中文字幕专区 | 午夜精品久久久久久久99热 | youjizz中国 | 亚洲国产精品一区 | 香蕉久久精品 | 青青爽| 一区二区三区在线 | 91精品国产品国语在线不卡 | 亚洲精品中文字幕久久久久久 | 国产精品在线播放 | 日本私人影院 |