亚洲免费在线-亚洲免费在线播放-亚洲免费在线观看-亚洲免费在线观看视频-亚洲免费在线看-亚洲免费在线视频

Beans-hdu-2845

系統 2359 0


Beans

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1977Accepted Submission(s): 997


Problem Description
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.
Beans-hdu-2845

Now, how much qualities can you eat and then get ?

Input
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.

Output
For each case, you just output the MAX qualities you can eat and then get.

Sample Input
      
4 6 11 0 7 5 13 9 78 4 81 6 22 4 1 40 9 34 16 10 11 22 0 33 39 6

Sample Output
      
242

重點: 橫豎分別求一下不連續的最大子段和;



    #include <iostream>
using namespace std;
int beans[100][100],line[100],row[100];
int main() {
	int m,n;
	while(cin >> m >> n){
		for(int i=0; i<m; i++){
			cin >> beans[i][0] >> beans[i][1];
			row[0] = beans[i][0];
			row[1] = beans[i][1];
			int tmpmax = max(row[0],row[1]);
			row[1] = tmpmax;
			for(int j=2; j<n; j++){
				cin >> beans[i][j];
				row[j] = max(row[j-2] + beans[i][j], row[j-1]);
			}
			line[i] = row[n-1];
		}
		int ans = max(line[0],line[1]);
		line[1] = ans;
		for(int i=2; i<m; i++){
			line[i] = max(line[i-2] + line[i], line[i-1]);
//			if(ans < line[i])
//				ans = line[i];
		}
		cout << line[m-1]  << endl;

	}
	return 0;
}
  




Beans-hdu-2845


更多文章、技術交流、商務合作、聯系博主

微信掃碼或搜索:z360901061

微信掃一掃加我為好友

QQ號聯系: 360901061

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描下面二維碼支持博主2元、5元、10元、20元等您想捐的金額吧,狠狠點擊下面給點支持吧,站長非常感激您!手機微信長按不能支付解決辦法:請將微信支付二維碼保存到相冊,切換到微信,然后點擊微信右上角掃一掃功能,選擇支付二維碼完成支付。

【本文對您有幫助就好】

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描上面二維碼支持博主2元、5元、10元、自定義金額等您想捐的金額吧,站長會非常 感謝您的哦!!!

發表我的評論
最新評論 總共0條評論
主站蜘蛛池模板: 国内外一级毛片 | 国产a精品 | 色综合99 | 国产观看精品一区二区三区 | 国产高清精品久久久久久久 | 久久er国产精品免费观看1 | 久久久这里只有精品加勒比 | 国产精品香蕉一区二区三区 | 中文字幕一区视频一线 | 午夜免费福利网站 | 欧美一级日本一级韩国一级 | 99久久精品免费看国产情侣 | 手机看片高清日韩精品 | 97精品福利视频在线 | 狠狠综合久久久久综合 | 日韩中文字幕在线观看视频 | 男女啪啪网站 | 欧美成人观看视频在线 | 特黄特级毛片免费视 | 9999人体做爰大胆视频 | 欧美一区二区三区婷婷月色 | 99精品网 | 99国产精品热久久久久久 | 国产看色免费 | 国产成人午夜精品影院游乐网 | 国产精品免费在线播放 | 一级成人生活片免费看 | 荔枝污 | 91福利在线免费观看 | 18p爽视频在线观看免费 | 伊人久热这里只精品视频 | 久久这里有精品视频 | 99在线精品日韩一区免费国产 | 国产精久久一区二区三区 | 黄色毛片视频 | 四虎精品成人a在线观看 | 欧美日韩精品一区三区 | 午夜亚洲国产理论秋霞 | 日韩不卡视频在线观看 | 九九香蕉视频 | 亚洲综合区小说区激情区噜噜 |