亚洲免费在线-亚洲免费在线播放-亚洲免费在线观看-亚洲免费在线观看视频-亚洲免费在线看-亚洲免费在线视频

Beans-hdu-2845

系統 2359 0


Beans

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1977Accepted Submission(s): 997


Problem Description
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.
Beans-hdu-2845

Now, how much qualities can you eat and then get ?

Input
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.

Output
For each case, you just output the MAX qualities you can eat and then get.

Sample Input
      
4 6 11 0 7 5 13 9 78 4 81 6 22 4 1 40 9 34 16 10 11 22 0 33 39 6

Sample Output
      
242

重點: 橫豎分別求一下不連續的最大子段和;



    #include <iostream>
using namespace std;
int beans[100][100],line[100],row[100];
int main() {
	int m,n;
	while(cin >> m >> n){
		for(int i=0; i<m; i++){
			cin >> beans[i][0] >> beans[i][1];
			row[0] = beans[i][0];
			row[1] = beans[i][1];
			int tmpmax = max(row[0],row[1]);
			row[1] = tmpmax;
			for(int j=2; j<n; j++){
				cin >> beans[i][j];
				row[j] = max(row[j-2] + beans[i][j], row[j-1]);
			}
			line[i] = row[n-1];
		}
		int ans = max(line[0],line[1]);
		line[1] = ans;
		for(int i=2; i<m; i++){
			line[i] = max(line[i-2] + line[i], line[i-1]);
//			if(ans < line[i])
//				ans = line[i];
		}
		cout << line[m-1]  << endl;

	}
	return 0;
}
  




Beans-hdu-2845


更多文章、技術交流、商務合作、聯系博主

微信掃碼或搜索:z360901061

微信掃一掃加我為好友

QQ號聯系: 360901061

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描下面二維碼支持博主2元、5元、10元、20元等您想捐的金額吧,狠狠點擊下面給點支持吧,站長非常感激您!手機微信長按不能支付解決辦法:請將微信支付二維碼保存到相冊,切換到微信,然后點擊微信右上角掃一掃功能,選擇支付二維碼完成支付。

【本文對您有幫助就好】

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描上面二維碼支持博主2元、5元、10元、自定義金額等您想捐的金額吧,站長會非常 感謝您的哦!!!

發表我的評論
最新評論 總共0條評論
主站蜘蛛池模板: 成人性色生活片全黄 | 不卡的| 可以免费观看的一级毛片 | 热99re久久国超精品首页 | 国产区成人精品视频 | 羞羞视频在线免费 | 在线观看片成人免费视频 | 色拍拍欧美视频在线看 | 一区二区三区免费视频观看 | 婷婷涩五月| 国产成人综合网在线观看 | 色姑娘综合 | 夜夜做日日做夜夜爽 | 桃色成人精品网站 | 亚洲黄色大片 | 亚洲国产一区二区三区四区五区 | 国产一区二区在线不卡 | 亚洲国产香蕉视频欧美 | 久草在线资源 | 四虎在线最新地址公告 | 九九九九热精品免费视频 | 免费精品国产自产拍观看 | 四虎在线影视在线影库 | 98色花堂国产精品首页 | 亚洲精品免费在线视频 | 欧美成 人激情视频 | 午夜视频在线观看国产www | 97久久精品人人做人人爽 | 激情小视频在线播放免费 | 福利在线视频一区热舞 | 亚洲精品亚洲人成在线 | 欧美成人久久久 | 亚洲高清一区二区三区久久 | 精品玖玖玖视频在线观看 | 亚洲黑人巨大videos0 | 一区二区视频在线观看免费的 | 免费观看一级毛片 | 国产精品12 | 亚洲一区二区久久 | 亚洲综合视频网 | 99热这里只有精品在线播放 |