亚洲免费在线-亚洲免费在线播放-亚洲免费在线观看-亚洲免费在线观看视频-亚洲免费在线看-亚洲免费在线视频

Complete the Sequence[HDU1121]

系統 2374 0

Complete the Sequence

Time Limit: 3000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 202????Accepted Submission(s): 119

Problem Description
You probably know those quizzes in Sunday magazines: given the sequence 1, 2, 3, 4, 5, what is the next number? Sometimes it is very easy to answer, sometimes it could be pretty hard. Because these "sequence problems" are very popular, ACM wants to implement them into the "Free Time" section of their new WAP portal.
ACM programmers have noticed that some of the quizzes can be solved by describing the sequence by polynomials. For example, the sequence 1, 2, 3, 4, 5 can be easily understood as a trivial polynomial. The next number is 6. But even more complex sequences, like 1, 2, 4, 7, 11, can be described by a polynomial. In this case, 1/2.n^2-1/2.n+1 can be used. Note that even if the members of the sequence are integers, polynomial coefficients may be any real numbers.

?

Polynomial is an expression in the following form:

?


P(n) = aD.n^D+aD-1.n^D-1+...+a1.n+a0

?


. If aD <> 0, the number D is called a degree of the polynomial. Note that constant function P(n) = C can be considered as polynomial of degree 0, and the zero function P(n) = 0 is usually defined to have degree -1.

?

?

?

Input
There is a single positive integer T on the first line of input. It stands for the number of test cases to follow. Each test case consists of two lines. First line of each test case contains two integer numbers S and C separated by a single space, 1 <= S < 100, 1 <= C < 100, (S+C) <= 100. The first number, S, stands for the length of the given sequence, the second number, C is the amount of numbers you are to find to complete the sequence.

?

The second line of each test case contains S integer numbers X1, X2, ... XS separated by a space. These numbers form the given sequence. The sequence can always be described by a polynomial P(n) such that for every i, Xi = P(i). Among these polynomials, we can find the polynomial Pmin with the lowest possible degree. This polynomial should be used for completing the sequence.

?

?

?

Output
For every test case, your program must print a single line containing C integer numbers, separated by a space. These numbers are the values completing the sequence according to the polynomial of the lowest possible degree. In other words, you are to print values Pmin(S+1), Pmin(S+2), .... Pmin(S+C).

?

It is guaranteed that the results Pmin(S+i) will be non-negative and will fit into the standard integer type.

?

?

?

Sample Input
4
6 3
1 2 3 4 5 6
8 2
1 2 4 7 11 16 22 29
10 2
1 1 1 1 1 1 1 1 1 2
1 10
3
?

?

Sample Output
7 8 9
37 46
11 56
3 3 3 3 3 3 3 3 3 3
?

?

Source
Central Europe 2000
?

?

Recommend
JGShining

不斷兩兩作差直到全部相等或只剩一個元素,之后遞推求解.

      #include<stdio.h>

int y[200][200];

int S,C;

bool finish(int x)

{

	int i;

	for (i=1+x;i<S;i++)

		if (y[x][i]!=y[x][i+1]) return false;

	return true;

}

int main()

{

	int T,i,j;

	scanf("%d",&T);

	while (T--)

	{

		scanf("%d%d",&S,&C);

		for (i=1;i<=S;i++) scanf("%d",&y[0][i]);

		int D=0;

		while (!finish(D))

		{

			D++;

			for (i=1+D;i<=S;i++) y[D][i]=y[D-1][i]-y[D-1][i-1];

		}

		for (i=1;i<=C;i++) y[D][S+i]=y[D][S+i-1];

		for (i=D-1;i>=0;i--)

			for (j=1;j<=C;j++)

				y[i][S+j]=y[i][S+j-1]+y[i+1][S+j];

		for (i=1;i<C;i++) printf("%d ",y[0][S+i]);

		printf("%d\n",y[0][S+C]);

	}

	return 0;

}


    

?

Complete the Sequence[HDU1121]


更多文章、技術交流、商務合作、聯系博主

微信掃碼或搜索:z360901061

微信掃一掃加我為好友

QQ號聯系: 360901061

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描下面二維碼支持博主2元、5元、10元、20元等您想捐的金額吧,狠狠點擊下面給點支持吧,站長非常感激您!手機微信長按不能支付解決辦法:請將微信支付二維碼保存到相冊,切換到微信,然后點擊微信右上角掃一掃功能,選擇支付二維碼完成支付。

【本文對您有幫助就好】

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描上面二維碼支持博主2元、5元、10元、自定義金額等您想捐的金額吧,站長會非常 感謝您的哦!!!

發表我的評論
最新評論 總共0條評論
主站蜘蛛池模板: 亚洲毛片在线观看 | 日本一级特黄毛片免费视频9 | 久久99精品久久久久久秒播放器 | 69做爰视频在线观看 | 狠狠色丁香久久婷婷综合_中 | 成年女人在线观看 | 欧美日韩在线成人免费视频大全 | 99精品国产免费久久国语 | 日韩中文字幕久久精品 | 免费一看一级毛片 | 黄页在线免费观看 | 久久精品国产国产精品四凭 | 一区二区三区视频观看 | 亚洲美女视频网站 | 亚洲国产99在线精品一区69堂 | 欧美高清国产 | 国产精品主播在线 | 久久精品123 | 欧美成人免费香蕉 | 免费在线一区二区三区 | 手机看片日韩欧美 | 五月综合在线 | 色综色天天综合网 | 国产精品综合网 | 亚洲视频在线观看视频 | 天天干干 | 日本在线一区二区三区 | 黄色福利在线观看 | 国产免费自拍视频 | 99精品久久 | 国产欧美成人 | 视频一区二区国产无限在线观看 | 四虎最新永久在线精品免费 | 99精品视频在线视频免费观看 | 国产精品国产三级国产专区5o | 免费视频福利 | 久久一区二区免费播放 | 综合色图 | 91香蕉国产亚洲一区二区三区 | 亚洲国产女人aaa毛片在线 | 日日夜夜操视频 |