亚洲免费在线-亚洲免费在线播放-亚洲免费在线观看-亚洲免费在线观看视频-亚洲免费在线看-亚洲免费在线视频

輸出問題問題一百二十八:IBM Minus One

系統(tǒng) 1664 0

每日一貼,今天的內(nèi)容關(guān)鍵字為輸出問題

????

You may have heard of the book '2001 - A Space Odyssey' by Arthur C. Clarke, or the film of the same name by Stanley Kubrick. In it a spaceship is sent from Earth to Saturn. The crew is put into stasis for the long flight, only two men are awake, and the ship is controlled by the intelligent computer HAL. But during the flight HAL is acting more and more strangely, and even starts to kill the crew on board. We don't tell you how the story ends, in case you want to read the book for yourself :-)

After the movie was released and became very popular, there was some discussion as to what the name 'HAL' actually meant. Some thought that it might be an abbreviation for 'Heuristic ALgorithm'. But the most popular explanation is the following: if you replace every letter in the word HAL by its successor in the alphabet, you get ... IBM.

Perhaps there are even more acronyms related in this strange way! You are to write a program that may help to find this out.

???? Input

????

The input starts with the integer n on a line by itself - this is the number of strings to follow. The following n lines each contain one string of at most 50 upper-case letters.

???? Output

????每日一道理
整個世界,因為有了陽光,城市有了生機;細小心靈,因為有了陽光,內(nèi)心有了舒暢。明媚的金黃色,樹叢間小影成像在葉片上泛有的點點破碎似的金燦,海面上直射反映留有的隨波浪層層翻滾的碎片,為這大自然創(chuàng)造了美景,惹人醉的溫馨之感,濃濃暖意中夾雜著的明朗與柔情,讓雨過天晴后久違陽光的心靈重新得到了滋潤!

????

For each string in the input, first output the number of the string, as shown in the sample output. The print the string start is derived from the input string by replacing every time by the following letter in the alphabet, and replacing 'Z' by 'A'.

Print a blank line after each test case.

???? Sample Input

    2

HAL

SWERC
  

???? Sample Output

    String #1

IBM



String #2

TXFSD
  
  
    #include <stdio.h>

#include <string.h>



int main()

{

     int  length;

     int  num;

     int i;

     int  count=1;

     char array[51];



     scanf("%d", &num);

     getchar();



     while(num--)

     {    

          gets(array);

   

          length=strlen(array);

          for(i=0; i<length; i++)

          {

              if(array[i]>='A' && array[i]<'Z')

              {

                  array[i]+=1;

              }

              else if(array[i]=='Z')

              {

                  array[i]='A';

              }

          }

          printf("String #%d\n", count++);



          for(i=0; i<length; i++)

          {

              printf("%c", array[i]);          

          }

          

              printf("\n\n");

          

     }



     return 0;

}
  

輸出問題問題一百二十八:IBM Minus One

    (該題輸出有點問題,即輸出都空行)
  

文章結(jié)束給大家分享下程序員的一些笑話語錄: 問答
Q:你是怎么區(qū)分一個內(nèi)向的程序員和一個外向的程序員的? A:外向的程序員會看著你的鞋和你說話時。
Q:為什么程序員不能區(qū)分萬圣節(jié)和圣誕節(jié)? A:這是因為 Oct 31 == Dec 25!(八進制的 31==十進制的 25)

輸出問題問題一百二十八:IBM Minus One


更多文章、技術(shù)交流、商務(wù)合作、聯(lián)系博主

微信掃碼或搜索:z360901061

微信掃一掃加我為好友

QQ號聯(lián)系: 360901061

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描下面二維碼支持博主2元、5元、10元、20元等您想捐的金額吧,狠狠點擊下面給點支持吧,站長非常感激您!手機微信長按不能支付解決辦法:請將微信支付二維碼保存到相冊,切換到微信,然后點擊微信右上角掃一掃功能,選擇支付二維碼完成支付。

【本文對您有幫助就好】

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描上面二維碼支持博主2元、5元、10元、自定義金額等您想捐的金額吧,站長會非常 感謝您的哦!!!

發(fā)表我的評論
最新評論 總共0條評論
主站蜘蛛池模板: 99久热只有精品视频免费看 | 久操热 | 香蕉久久久久 | 欧美性猛交99久久久久99 | 性欧美4k高清精品 | 在线观看不卡视频 | 亚洲精品综合在线 | 欧美日韩在线观看免费 | 99影视网 | 日日骑夜夜操 | 俄罗斯aaaa一级毛片 | www四虎| 久久久久久久久亚洲 | 在线视频中文字幕 | 一本清高清dvd日本播放器 | 99j久久精品久久久久久 | 日韩亚洲一区中文字幕在线 | 天堂成人一区二区三区 | 国产在线视频福利 | 一级毛片在线视频 | 精品久久视频 | 久草视频免费在线播放 | 羞羞的视频在线观看 | 亚洲国产午夜精品理论片的软件 | 激情亚州| 日韩一区二区在线免费观看 | 国产一区二 | 香蕉色香蕉在线视频 | 九九九国产 | 日本又黄又爽又色的视频免费 | 99久久精品国产免费 | se01国产短视频在线观看 | 99久久综合九九亚洲 | 精品国产免费久久久久久婷婷 | 大尺度毛片 | 国产一区二区精品在线观看 | 国产精品资源在线 | 精品日韩 | 日韩免费中文字幕 | 97精品视频共享总站 | 亚洲国产中文字幕在线观看 |