亚洲免费在线-亚洲免费在线播放-亚洲免费在线观看-亚洲免费在线观看视频-亚洲免费在线看-亚洲免费在线视频

SZU:B54 Dual Palindromes

系統(tǒng) 1760 0

Judge Info

  • Memory Limit: 32768KB
  • Case Time Limit: 10000MS
  • Time Limit: 10000MS
  • Judger: Number Only Judger

Description

A number that reads the same from right to left as when read from left to right is called a palindrome. The number 12321 is a palindrome; the number 77778 is not. Of course, palindromes have neither leading nor trailing zeroes, so 0220 is not a palindrome.

The number 21 (base 10) is not palindrome in base 10, but the number 21 (base 10) is, in fact, a palindrome in base 2 (10101).

Write a program that reads two numbers (expressed in base 10):

  • N (1 <= N <= 15)
  • S (0 < S < 10000)

and then finds and prints (in base 10) the first N numbers strictly greater than S that are palindromic when written in two or more number bases (2 <= base <= 10). Solutions to this problem do not require manipulating integers larger than the standard 32 bits.

Input

The first line of input contains?, the number of test cases.

For each test case, there is a single line with space separated integers N and S.

Output

For each test case output N lines, each with a base 10 number that is palindromic when expressed in at least two of the bases 2..10. The numbers should be listed in order from smallest to largest.

Sample Input

    2

3 25

1 25


  

Sample Output

    26

27

28

26
  

?

解題思路:找兩個1~10進制之間的回文數(shù)字,當時看成找1個回文數(shù)字就可以通過,所以導致好久才AC,看題失誤!

      
         1
      
       #include <stdio.h>


      
         2
      
       #include <
      
        string
      
      .h>


      
         3
      
      
         4
      
      
        char
      
       A[
      
        200
      
      
        ];


      
      
         5
      
      
        int
      
      
         main()


      
      
         6
      
      
        {


      
      
         7
      
      
        int
      
      
         num,r,i,n,j,t,k,ke,mark,len,last,flag;


      
      
         8
      
           scanf(
      
        "
      
      
        %d
      
      
        "
      
      ,&
      
        n);


      
      
         9
      
      
        while
      
      (n--
      
        ){


      
      
        10
      
               scanf(
      
        "
      
      
        %d %d
      
      
        "
      
      ,&last, &
      
        k);


      
      
        11
      
      
        while
      
      (last--
      
        ){


      
      
        12
      
                   ++
      
        k;


      
      
        13
      
      
        14
      
                   flag=
      
        0
      
      
        ;


      
      
        15
      
      
        for
      
      (r=
      
        2
      
      ;r<=
      
        10
      
      ;r++
      
        ){


      
      
        16
      
                       i=
      
        0
      
      
        ;


      
      
        17
      
                       num=
      
        k;


      
      
        18
      
                       mark=
      
        1
      
      
        ;


      
      
        19
      
      
        20
      
      
        while
      
      (num>
      
        0
      
      
        ){


      
      
        21
      
                           t=num%
      
        r;


      
      
        22
      
                           A[i]= t+
      
        '
      
      
        0
      
      
        '
      
      
        ;    


      
      
        23
      
                           ++
      
        i;


      
      
        24
      
                           num/=
      
        r;


      
      
        25
      
      
                        }


      
      
        26
      
                        len = i-
      
        1
      
      
        ;


      
      
        27
      
      
        28
      
      
        for
      
      (i=
      
        0
      
      ,j=len;i<=j;i++,j--
      
        ){


      
      
        29
      
      
        if
      
      (A[i]!=
      
        A[j])


      
      
        30
      
                               mark=
      
        0
      
      
        ;


      
      
        31
      
      
                        }


      
      
        32
      
      
        33
      
      
        if
      
      (mark==
      
        1
      
      
        ){


      
      
        34
      
                           flag++
      
        ;


      
      
        35
      
      
                        }


      
      
        36
      
      
        if
      
      (flag==
      
        2
      
      
        ){


      
      
        37
      
                           printf(
      
        "
      
      
        %d\n
      
      
        "
      
      
        , k);


      
      
        38
      
      
        break
      
      
        ;                    


      
      
        39
      
      
                        }


      
      
        40
      
      
                    }


      
      
        41
      
      
        if
      
      (flag!=
      
        2
      
      
        )


      
      
        42
      
                       ++
      
        last;


      
      
        43
      
      
                }


      
      
        44
      
      
            }


      
      
        45
      
      
        return
      
      
        0
      
      
        ;


      
      
        46
      
       }
    

?

SZU:B54 Dual Palindromes


更多文章、技術交流、商務合作、聯(lián)系博主

微信掃碼或搜索:z360901061

微信掃一掃加我為好友

QQ號聯(lián)系: 360901061

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描下面二維碼支持博主2元、5元、10元、20元等您想捐的金額吧,狠狠點擊下面給點支持吧,站長非常感激您!手機微信長按不能支付解決辦法:請將微信支付二維碼保存到相冊,切換到微信,然后點擊微信右上角掃一掃功能,選擇支付二維碼完成支付。

【本文對您有幫助就好】

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描上面二維碼支持博主2元、5元、10元、自定義金額等您想捐的金額吧,站長會非常 感謝您的哦!!!

發(fā)表我的評論
最新評論 總共0條評論
主站蜘蛛池模板: 网红福利在线 | 青青青爽视频在线观看 | 亚洲一级毛片视频 | 欧美亚洲另类色国产综合 | 香蕉福利久久福利久久香蕉 | 亚洲欧美一区二区久久香蕉 | 国产91在线chines看 | 黄色毛片一级 | 久久精品视频6 | 欧美一级毛片一免费 | 91精品国产高清久久久久 | 瑟瑟视频在线观看 | 久久在线视频免费观看 | 欧美色视频日本片免费高清 | 日本草草影院 | 欧美一级成人影院免费的 | 国产精品毛片久久久久久久 | 成人深夜视频在线观看 | 色人阁网站| heyzo在线播放4k岛国 | 精彩视频一区二区 | 天天爱天天色天天干 | 91麻豆精品一二三区在线 | 免费国产成人午夜私人影视 | 精品国精品国产自在久国产不卡 | 日本一级淫片a免费播放 | 久久老色鬼天天综合网观看 | 日本老年人精品久久中文字幕 | 天天躁天天碰天天看 | 97影院理论在线观看 | 99青青青精品视频在线 | 香蕉福利久久福利久久香蕉 | 日韩高清在线日韩大片观看网址 | 高清视频 一区二区三区四区 | 久久亚洲国产精品五月天婷 | 国产在线播放一区 | 日韩成人综合网 | 一级片aaaaaa | www.中文字幕| 麻豆久久精品 | 久久99久久99精品免观看动漫 |