亚洲免费在线-亚洲免费在线播放-亚洲免费在线观看-亚洲免费在线观看视频-亚洲免费在线看-亚洲免费在线视频

【PAT】1035. Password (20)

系統 2115 0

題目: http://pat.zju.edu.cn/contests/pat-a-practise/1035

分析: 簡單題。直接搜索,然后替換,不會超時,但是應該有更好的辦法。

題目描述:

?

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line "There are N accounts and no account is modified" where N is the total number of accounts. However, if N is one, you must print "There is 1 account and no account is modified" instead.

Sample Input 1:

      3

Team000002 Rlsp0dfa

Team000003 perfectpwd

Team000001 R1spOdfa


    
Sample Output 1:
      2

Team000002 RLsp%dfa

Team000001 R@spodfa


    
Sample Input 2:
      1

team110 abcdefg332


    
Sample Output 2:
      There is 1 account and no account is modified


    
Sample Input 3:
      2

team110 abcdefg222

team220 abcdefg333


    
Sample Output 3:
      There are 2 accounts and no account is modified


    

?


參考代碼:

?

    #include<iostream>

#include<string.h>

#include<string>

using namespace std;



class User

{

public:

	void set(string nam,string pas)

	{

		name = nam;

		pass = pas;

		is_Changed = false;

	};

	User(){};//此處要注意!!!如果寫成User();則不能運行!

	

	void check();	

	void show();

	bool is_Changed;

private:	

	string name;

	string pass;	

	int len;

};



void User::show()

{

	cout<<name<<" "<<pass<<endl; 

}



void User::check()

{

	len = pass.length();

	int i;

	for(i=0; i<len; i++)

	{

		if(pass[i] == '1') {pass[i] = '@'; is_Changed = true;}

		else if(pass[i] == '0') {pass[i] = '%'; is_Changed = true;}

		else if(pass[i] == 'l') {pass[i] = 'L'; is_Changed = true;}

		else if(pass[i] == 'O') {pass[i] = 'o'; is_Changed = true;}

	}

}



int main()

{

	int N;

	int i;

	string nam,pas;

	int count = 0;

	cin>>N;

	User *u = new User[N];

	for(i=0; i<N; i++)

	{

		cin>>nam>>pas;

		u[i].set(nam,pas);

		u[i].check();

		if(u[i].is_Changed) { count++; }

	}

	if(count == 0)

	{

		if(N != 1)

			cout<<"There are "<<N<<" accounts and no account is modified"<<endl;

		else

			cout<<"There is 1 account and no account is modified"<<endl;

	}

			

	else

	{

		cout<<count<<endl;

		for(i=0; i<N; i++)

			if(u[i].is_Changed) u[i].show();	

	} 

	return 0;

}
  


?




?

【PAT】1035. Password (20)


更多文章、技術交流、商務合作、聯系博主

微信掃碼或搜索:z360901061

微信掃一掃加我為好友

QQ號聯系: 360901061

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描下面二維碼支持博主2元、5元、10元、20元等您想捐的金額吧,狠狠點擊下面給點支持吧,站長非常感激您!手機微信長按不能支付解決辦法:請將微信支付二維碼保存到相冊,切換到微信,然后點擊微信右上角掃一掃功能,選擇支付二維碼完成支付。

【本文對您有幫助就好】

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描上面二維碼支持博主2元、5元、10元、自定義金額等您想捐的金額吧,站長會非常 感謝您的哦!!!

發表我的評論
最新評論 總共0條評論
主站蜘蛛池模板: 亚洲精品国产一区二区三区在 | 久久精品片| 天天夜碰日日摸日日澡 | 四虎影视免费看 | 国产成人精品一区二区三区 | 国产伦一区二区三区免费 | 中文精品视频一区二区在线观看 | 国产香蕉视频在线观看 | 久久婷婷综合中文字幕 | 亚洲天堂资源 | 日韩一级大毛片欧美一级 | 成人美女隐私免费 | 99在线资源| 久久网站在线观看 | 日韩中文字幕视频在线观看 | 久久精品国产99国产精品澳门 | 亚洲成人精品久久 | 日韩欧美一区在线观看 | 国产成人一区二区在线不卡 | 男女啪啪猛烈免费网站 | www.五月天婷婷 | 久久视频在线免费观看 | 欧美一二三区 | 久久精品久久精品久久精品 | 操你妹影院 | 伊人久久综合谁合综合久久 | 亚洲社区在线 | 一级中国毛片 | 亚洲美女啪啪 | 亚洲欧洲一二三区机械有限公司 | 亚洲 欧美 bt | 四虎影视国产在线观看精品 | 国产精品揄拍一区二区久久 | 国产精品视频全国免费观看 | 久久天天躁狠狠躁夜夜不卡 | 国产一区二区三区久久精品小说 | 日韩中文视频 | 奇米七七七 | 夜夜夜夜夜夜夜工噜噜噜 | 四虎影视紧急入口地址大全 | 成人免费动作大片黄在线 |