亚洲免费在线-亚洲免费在线播放-亚洲免费在线观看-亚洲免费在线观看视频-亚洲免费在线看-亚洲免费在线视频

[ACM] poj 1064 Cable master (二進(jìn)制搜索)

系統(tǒng) 2421 0
Cable master
Time Limit: 1000MS ? Memory Limit: 10000K
Total Submissions: 21071 ? Accepted: 4542

Description

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).

Sample Input

      4 11

8.02

7.43

4.57

5.39
    

Sample Output

      2.00
    

Source

?

解題思路:

N條繩子,長(zhǎng)度為別為li,要截成長(zhǎng)度相等的K段,問(wèn)切成小段的最大長(zhǎng)度是多少。有的繩子能夠不切。

也就是求一個(gè)x ,?? l1/ x +l2/x +l3/x +.....=K,求最大的x。

求的過(guò)程中中間值x 。假設(shè)>k也是符合題意的。要求最大的x。==k.

條件C(x)=能夠得到K條長(zhǎng)度為x的繩子

區(qū)間l=0,r等于無(wú)窮大,二分。推斷是否符合c(x) C(x)=(floor(Li/x)的總和大于或等于K

代碼:

      #include <iostream>

#include <iomanip>

#include <stdio.h>

#include <cmath>

using namespace std;

const int maxn=10003;

const int inf=0x7fffffff;

double l[maxn];

int n,k;



bool ok(double x)//推斷x是否可行

{

    int num=0;

    for(int i=0;i<n;i++)

    {

        num+=(int)(l[i]/x);

    }

    return num>=k;//被分成的段數(shù)大于等于K才可行

}



int main()

{

    cin>>n>>k;

    for(int i=0;i<n;i++)

        scanf("%lf",&l[i]);

    double l=0,r=inf;

    for(int i=0;i<100;i++)//二分,直到解的范圍足夠小

    {

        double mid=(l+r)/2;

        if(ok(mid))

            l=mid;

        else

            r=mid;

    }

    cout<<setiosflags(ios::fixed)<<setprecision(2)<<floor(l*100)/100;//l和r最后相等

    return 0;

}


    


?

版權(quán)聲明:本文博客原創(chuàng)文章,博客,未經(jīng)同意,不得轉(zhuǎn)載。

[ACM] poj 1064 Cable master (二進(jìn)制搜索)


更多文章、技術(shù)交流、商務(wù)合作、聯(lián)系博主

微信掃碼或搜索:z360901061

微信掃一掃加我為好友

QQ號(hào)聯(lián)系: 360901061

您的支持是博主寫作最大的動(dòng)力,如果您喜歡我的文章,感覺我的文章對(duì)您有幫助,請(qǐng)用微信掃描下面二維碼支持博主2元、5元、10元、20元等您想捐的金額吧,狠狠點(diǎn)擊下面給點(diǎn)支持吧,站長(zhǎng)非常感激您!手機(jī)微信長(zhǎng)按不能支付解決辦法:請(qǐng)將微信支付二維碼保存到相冊(cè),切換到微信,然后點(diǎn)擊微信右上角掃一掃功能,選擇支付二維碼完成支付。

【本文對(duì)您有幫助就好】

您的支持是博主寫作最大的動(dòng)力,如果您喜歡我的文章,感覺我的文章對(duì)您有幫助,請(qǐng)用微信掃描上面二維碼支持博主2元、5元、10元、自定義金額等您想捐的金額吧,站長(zhǎng)會(huì)非常 感謝您的哦!!!

發(fā)表我的評(píng)論
最新評(píng)論 總共0條評(píng)論
主站蜘蛛池模板: 欧美级毛片 | 在线成人tv天堂中文字幕 | 久久综合中文字幕 | 欧美一级夜夜爽 视频 | 4hu四虎免费影院www | 国产激情对白一区二区三区四 | 四虎在线成人免费网站 | 全部费免一级毛片不收费 | 性xxxxbbbbxxxx中国| 国产成人精品免费视频 | 国产高清美女一级a毛片久久 | 亚洲码和乱人伦中文一区 | 亚洲加勒比久久88色综合一区 | 国产精品乱码免费一区二区 | 99re热精品视频国产免费 | 亚洲阿v天堂在线观看2017 | 一级a毛片 | 亚洲不卡免费视频 | 久久国产精品99国产精 | 99视频久久| 久久精品在线视频 | 欧美大香 | 日韩免费福利视频 | 国产色视频 | 久久精品国产91久久麻豆自制 | 九九精彩视频在线观看视频 | 在线视频不卡国产在线视频不卡 | 色婷婷综合久久久久中文一区二区 | 亚洲品质自拍视频 | av中文字幕在线 | 成人欧美一区二区三区白人 | 欧美成人免费tv在线播放 | 精品欧美一区二区三区在线 | 国产成人精品男人免费 | 香蕉福利 | 久久精品日日躁夜夜躁欧美 | 欧美乱一级在线观看 | 欧美日韩国产高清视频 | 手机看片日韩高清国产欧美 | 色综合久久久久综合体桃花网 | 精品日韩一区二区三区视频 |