亚洲免费在线-亚洲免费在线播放-亚洲免费在线观看-亚洲免费在线观看视频-亚洲免费在线看-亚洲免费在线视频

zoj 1825 Compound Words

系統 1819 0
ZOJ Problem Set - 1825
Compound Words

Time Limit: 5 Seconds ???? Memory Limit: 32768 KB

You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.


Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.


Output

Your output should contain all the compound words, one per line, in alphabetical order.


Sample Input

a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra


Sample Output

alien
newborn


Source: University of Waterloo Local Contest 1996.09.28
Submit ?? Status
// 1846335?2009-04-28?15:41:20?Accepted??1825?C++?270?1240?Wpl?
#include? < iostream >
#include?
< string >
#include?
< set >
using ? namespace ?std;
set < string > S;
set < string > ::iterator?p;
int ?main()
{
????
string ?str,str1,str2;
????S.clear();
????
int ?len,i;
????
while (cin >> str)
????{
????????S.insert(str);
????}
????
for (p = S.begin();p != S.end();p ++ )
????{
????????str
=* p;
????????len
= str.length();
????????
for (i = 1 ;i < len;i ++ )
????????{
????????????str1
= str.substr( 0 ,i);
????????????str2
= str.substr(i,len - i);
????????????
if (S.find(str1) != S.end() && S.find(str2) != S.end())
????????????{
????????????????cout
<< str << endl;
????????????????
break ;
????????????}
????????}
????}
????
return ? 0 ;
}

?

//用map

?

// 1846363?2009-04-28?16:02:33?Wrong?Answer??1825?C++?410?3616?Wpl?
// 1846374?2009-04-28?16:11:40?Accepted??1825?C++?240?1372?Wpl?
#include? < iostream >
#include?
< map >
#include?
< string >
using ? namespace ?std;
map
< string , int > M;
map
< string , int > ::iterator?p;
int ?main()
{
????
string ?str,str1,str2;
????
int ?len,i;
????M.clear();
????
while (cin >> str)
????????M[str]
= 1 ;
????
for (p = M.begin();p != M.end();p ++ )
????{
????????str
= p -> first;
????????len
= str.length();
????????
for (i = 1 ;i < len;i ++ )
????????{
????????????str1
= str.substr( 0 ,i);
????????????str2
= str.substr(i,len - i);
????????
// ????if(M[str1]==1&&M[str2]==1)?? // 找數不用這樣找的,因為這樣會把那個數放進M里
???????????? if (M.find(str1)? != ?M.end()? && ?M.find(str2)? != ?M.end())
????????????{
????????????????cout
<< str << endl;
????????????????
break ;
????????????}
????????}
????}
????
return ? 0 ;
}

zoj 1825 Compound Words


更多文章、技術交流、商務合作、聯系博主

微信掃碼或搜索:z360901061

微信掃一掃加我為好友

QQ號聯系: 360901061

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描下面二維碼支持博主2元、5元、10元、20元等您想捐的金額吧,狠狠點擊下面給點支持吧,站長非常感激您!手機微信長按不能支付解決辦法:請將微信支付二維碼保存到相冊,切換到微信,然后點擊微信右上角掃一掃功能,選擇支付二維碼完成支付。

【本文對您有幫助就好】

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描上面二維碼支持博主2元、5元、10元、自定義金額等您想捐的金額吧,站長會非常 感謝您的哦!!!

發表我的評論
最新評論 總共0條評論
主站蜘蛛池模板: 国产a毛片清高视频 | 久青草国产高清在线视频 | 一级做人免费观看c欧美网站 | 国产精品18久久久久网站 | 视频在线一区二区三区 | 奇米色影视 | 日日夜夜中文字幕 | 性视频xxx | 国产91嫩草精品 | 四虎永久网址在线观看 | 久久精品国产精品亚洲婷婷 | 欧美成人视 | 四虎影视在线免费观看 | 欧美一级毛片国产一级毛片 | 日本久久久久一级毛片 | 欧美中文字幕一二三四区 | 男人天堂视频在线 | 午夜伦4480yy妇女久久久 | 久久综合日韩亚洲精品色 | 国产成+人+亚洲+欧美+日韩 | 欧美成人毛片 | 久久66热这里只会有精品 | 亚洲欧美色综合大色 | 欧美日韩不卡在线 | 手机看片日韩 | 亚洲人人干| 国产亚洲精品激情一区二区三区 | 国产最新精品 | 久久毛片免费 | 亚洲色欧美 | 久久亚洲国产的中文 | 农村三级孕妇视频在线 | 国产精品久久久久久久久久影院 | 欧美国产永久免费看片 | 97人人在线 | 久久综合久美利坚合众国 | 伊人久久综合视频 | 国内精品免费 | 国产精品一二区 | 久久亚洲不卡一区二区 | 国产成人精品一区二区仙踪林 |