You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.
Output
Your output should contain all the compound words, one per line, in alphabetical order.
Sample Input
a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra
Sample Output
alien
newborn
Source: University of Waterloo Local Contest 1996.09.28
#include? < iostream >
#include? < string >
#include? < set >
using ? namespace ?std;
set < string > S;
set < string > ::iterator?p;
int ?main()
{
???? string ?str,str1,str2;
????S.clear();
???? int ?len,i;
???? while (cin >> str)
????{
????????S.insert(str);
????}
???? for (p = S.begin();p != S.end();p ++ )
????{
????????str =* p;
????????len = str.length();
???????? for (i = 1 ;i < len;i ++ )
????????{
????????????str1 = str.substr( 0 ,i);
????????????str2 = str.substr(i,len - i);
???????????? if (S.find(str1) != S.end() && S.find(str2) != S.end())
????????????{
????????????????cout << str << endl;
???????????????? break ;
????????????}
????????}
????}
???? return ? 0 ;
}
?
//用map
?
// 1846374?2009-04-28?16:11:40?Accepted??1825?C++?240?1372?Wpl?
#include? < iostream >
#include? < map >
#include? < string >
using ? namespace ?std;
map < string , int > M;
map < string , int > ::iterator?p;
int ?main()
{
???? string ?str,str1,str2;
???? int ?len,i;
????M.clear();
???? while (cin >> str)
????????M[str] = 1 ;
???? for (p = M.begin();p != M.end();p ++ )
????{
????????str = p -> first;
????????len = str.length();
???????? for (i = 1 ;i < len;i ++ )
????????{
????????????str1 = str.substr( 0 ,i);
????????????str2 = str.substr(i,len - i);
???????? // ????if(M[str1]==1&&M[str2]==1)?? // 找數不用這樣找的,因為這樣會把那個數放進M里
???????????? if (M.find(str1)? != ?M.end()? && ?M.find(str2)? != ?M.end())
????????????{
????????????????cout << str << endl;
???????????????? break ;
????????????}
????????}
????}
???? return ? 0 ;
}
更多文章、技術交流、商務合作、聯系博主
微信掃碼或搜索:z360901061

微信掃一掃加我為好友
QQ號聯系: 360901061
您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描下面二維碼支持博主2元、5元、10元、20元等您想捐的金額吧,狠狠點擊下面給點支持吧,站長非常感激您!手機微信長按不能支付解決辦法:請將微信支付二維碼保存到相冊,切換到微信,然后點擊微信右上角掃一掃功能,選擇支付二維碼完成支付。
【本文對您有幫助就好】元
